Cinchy Platform Documentation
Cinchy v5.0.0
Search…
⌃K

Upgrading from v4 to v5

Table of Contents

1. Upgrading to v5 on Kubernetes

When you upgrade to Cinchy v5 on Kubernetes you are creating a separate instance. You will need to plan the migration of your database, and then follow the deployment installation guide.

2. Upgrading to v5 on IIS

To upgrade from v4+ to v5+ on IIS, review the documentation here.

3. Compatibility Issues Between Databases/Versions

If you choose to upgrade to Cinchy v5 on PostgreSQL, please review the following features that are not currently available in that deployment.
These may be implemented in future versions of the platform.
  • No Partitioning
  • No Geospatial
  • No Column Indexing
  • No Full Text Indexing
  • No Column Level Encryption
You may also wish to review the list of CQL functions currently unsupported in PGSQL. Please note that this is a living document and that the development team is actively working on function translations between databases. Make sure to check back for the most up to date information.